Errors when sending Deliveries with Outlook Add-In (classic)

Incident Report for FTAPI

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 12:24 CEST

Monitoring

The fix has been implemented for all customers and we are monitoring to verify.
Posted Jun 18, 2026 - 12:08 CEST

Update

We have rolled out the fix for >95% of affected customers. The remaining 5% will be fixed with the next 20 minutes.
Posted Jun 18, 2026 - 11:28 CEST

Update

We are still working on rolling out the fix to our customers and are expecting the issue to be resolved by 11:30 CEST.
Posted Jun 18, 2026 - 10:33 CEST

Update

We have found a solution for the issue and are currently rolling it out to our customers. This may cause downtime of up to 5 minutes for individual customers. We apologize for the service disruption.
Posted Jun 18, 2026 - 09:24 CEST

Identified

The issue is identified we will rollout fix in a few moments
Posted Jun 18, 2026 - 08:39 CEST

Investigating

We are currently investigating reports about error messages when trying to send Deliveries with the classic Outlook Add-In
Posted Jun 18, 2026 - 08:29 CEST
This incident affected: FTAPI Cloud Systems.