We needed to extend this maintenance window because of complications at the beginning. The individual downtime was not influence by this, we are sorry for any inconvenience.
Posted Jan 22, 2026 - 00:26 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 21, 2026 - 19:00 CET
Scheduled
We will update our service to the newest version. Services may be unavailable for up to 15 minutes.